Post

1 follower Follow
0
Avatar

ConnectCloud ACS command is not working in SDK 4.0

While executing ACS command ConnectCloud using Apprenda SDK version 4.0 then getting the following error, please assist.

"Unable to find IUser with Identifier ''. The finder method used was 'GetByUserName'.

Parachuri, Narendra

Please sign in to leave a comment.

6 comments

0
Avatar

Hi,

This problem may be caused because of a mismatch between the version of the platform and the version of the SDK. If both your platform and SDK are running Apprenda 4.0, please let me know.

Best Regards,

Bernie

Bernie Herdan 0 votes
0
Avatar

Hi,

I am having Visual Studio 2012 with 4.5 framework and installed Apprenda 4.0 SDK Installer from http://docs.apprenda.com/downloads. I used Developer command prompt for VS2012 and executed ACS commands registercloud and it worked fine but when I try to connect the cloud using ACS ConnectCloud then it is throwing the error.

 

Regards,

Narendra

Parachuri, Narendra 0 votes
0
Avatar

Hi Narendra,

I believe that you had installed the Apprenda Platform on version 3.5. As a result, you need to change your SDK to match that version.

In order to do that, first remove the Apprenda 4.0 SDK, and install the 3.5 SDK.

Regards,

Bernie

Bernie Herdan 0 votes
0
Avatar

Hi Narendra,

After you install the correct SDK, make sure you are also running Powershell as an Administrator.

Best Regards,

Bernie

Bernie Herdan 0 votes
0
Avatar

HI Bernie,

I installed SDK 4.0 and connected Apprenda cloud and trying to execute the ACS commands. Attached the screenshot of the operations. The commands are executing in SDK 3.5 but not in SDK 4.0

Parachuri, Narendra 0 votes